const regex = /handshake\/+reply\/+(?<deploy_client_name>[^\/]+)\/+(?<deploy_client>\S+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('handshake\\\/+reply\\\/+(?<deploy_client_name>[^\\\/]+)\\\/+(?<deploy_client>\\S+)', 'g')
const str = `tenantService/handshake/reply/ax/mx
tenantService/handshake/reply/Lx/wx1
tenantService/handshake/reply/Dx/wx2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}