$re = '/handshake\/+reply\/+(?<deploy_client_name>[^\/]+)\/+(?<deploy_client>\S+)/';
$str = 'tenantService/handshake/reply/ax/mx
tenantService/handshake/reply/Lx/wx1
tenantService/handshake/reply/Dx/wx2';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);