import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<div class=\"podEventRow[^>]+>(\\s*<div class=\"[^>]+>\\s*(<span[^>]+>|</span>|</?em>|[\\s0-9/,.+-]+)+[^<]*</div>\\s*)+</div>";
final String string = "<div class=\"podEventRow singleRow\" data-plbtid=\"50139\">\n"
+ " <div class=\"wideLeftColumn centered\"><em>4.0, 4.5</em></div>\n"
+ " <div class=\"priceColumn third \" data-nav=\"pt=N#o=27/5#f=54849113#fp=962365111#so=0#c=1#ln=4.25\" data-displayorder=\"27\">6.400</div>\n"
+ " <div class=\"priceColumn third \" data-nav=\"pt=N#o=23/200#f=54849113#fp=962365112#so=0#c=1#ln=4.25\" data-displayorder=\"28\">1.115</div>\n"
+ " </div>";
final Pattern pattern = Pattern.compile(regex, Pattern.DOTALL);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}