const regex = new RegExp('<div class="podEventRow[^>]+>(\\s*<div class="[^>]+>\\s*(<span[^>]+>|</span>|</?em>|[\\s0-9/,.+-]+)+[^<]*</div>\\s*)+</div>', 'gs')
const str = `<div class="podEventRow singleRow" data-plbtid="50139">
<div class="wideLeftColumn centered"><em>4.0, 4.5</em></div>
<div class="priceColumn third " data-nav="pt=N#o=27/5#f=54849113#fp=962365111#so=0#c=1#ln=4.25" data-displayorder="27">6.400</div>
<div class="priceColumn third " data-nav="pt=N#o=23/200#f=54849113#fp=962365112#so=0#c=1#ln=4.25" data-displayorder="28">1.115</div>
</div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}