re = /<div class="podEventRow[^>]+>(\s*<div class="[^>]+>\s*(<span[^>]+>|<\/span>|<\/?em>|[\s0-9\/,.+-]+)+[^<]*<\/div>\s*)+<\/div>/
str = '<div class="podEventRow singleRow" data-plbtid="50139">
<div class="wideLeftColumn centered"><em>4.0, 4.5</em></div>
<div class="priceColumn third " data-nav="pt=N#o=27/5#f=54849113#fp=962365111#so=0#c=1#ln=4.25" data-displayorder="27">6.400</div>
<div class="priceColumn third " data-nav="pt=N#o=23/200#f=54849113#fp=962365112#so=0#c=1#ln=4.25" data-displayorder="28">1.115</div>
</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end