# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<a href=".*(\/media\/video\/\d+\/)"*[^>]*>([^<]+)<\/a>)//;t' <<< "<div class=\"videoTitle\"><a href=\"/media/video/1234/\" title='ddd \"da\"'>
bla lba
</a></div>"