import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<a href=\".*(/media/video/\\d+/)\"*[^>]*>([^<]+)</a>)";
final String string = "<div class=\"videoTitle\"><a href=\"/media/video/1234/\" title='ddd \"da\"'>\n"
+ "bla lba\n"
+ "</a></div>";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}