import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Za-z][A-Za-z0-9]*) = \\1 \\+ [A-Za-z][A-Za-z0-9]*";
final String string = "A = A + B\n"
+ "ABZ = ABZ + B\n"
+ "FD = FD + B";
final String subst = "";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}