$re = '/([A-Za-z][A-Za-z0-9]*) = \1 \+ [A-Za-z][A-Za-z0-9]*/m';
$str = 'A = A + B
ABZ = ABZ + B
FD = FD + B';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;