re = /([A-Za-z][A-Za-z0-9]*) = \1 \+ [A-Za-z][A-Za-z0-9]*/m
str = 'A = A + B
ABZ = ABZ + B
FD = FD + B'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result