use strict;
my $str = 'A = A + B
ABZ = ABZ + B
FD = FD + B';
my $regex = qr/([A-Za-z][A-Za-z0-9]*) = \1 \+ [A-Za-z][A-Za-z0-9]*/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";