const regex = /input.*(?<=name=['|"])([\w]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('input.*(?<=name=[\'|"])([\\w]+)', 'g')
const str = `<form method="post" action="">
<input type="hidden" name="produto1" value="teste1">
<input type="hidden" name='produto2' value="teste2">
<input name="produto3" type="hidden" value="teste3">
<input type="hidden" name='produto4' value="teste4">
<input type="hidden" name="produto5" value="teste5">
<input type="submit" value="enviar">
</form>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}