use strict;
my $str = '<form method="post" action="">
<input type="hidden" name="produto1" value="teste1">
<input type="hidden" name=\'produto2\' value="teste2">
<input name="produto3" type="hidden" value="teste3">
<input type="hidden" name=\'produto4\' value="teste4">
<input type="hidden" name="produto5" value="teste5">
<input type="submit" value="enviar">
</form>';
my $regex = qr/input.*(?<=name=['|"])([\w]+)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}