re = /content=\\\"(?P<content>.*)\\\".*property=\\\"(?P<prop>.*)\\\"\/>/m
str = '<meta content=\\"Allrecipes\\" property=\\"og:site_name\\"/>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end