const regex = /[^\p{M}\w]+/ug;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^\\p{M}\\w]+', 'ug')
const str = `कपिल शर्मा % * _`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);