$re = '/[^\p{M}\w]+/u';
$str = 'कपिल शर्मा % * _';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;