$re = '/(^[A-Za-z0-9]{8}).*EXEC.*PGM=([A-Za-z0-9]*)(?:,PARM=\'([A-Za-z0-9,()=]*)\')?(?:,COND=\(([A-Za-z0-9,]*)\))?/m';
$str = 'STEP0010 EXEC PGM=SORT,PARM=\'SIZE(MAX),DYNALLOC=(SYSDA,15)\',COND=(0,NE)
STEPCTLG EXEC PGM=IEFBR14,COND=(4,LT)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);