import Foundation
let pattern = #"(^[A-Za-z0-9]{8}).*EXEC.*PGM=([A-Za-z0-9]*)(?:,PARM='([A-Za-z0-9,()=]*)')?(?:,COND=\(([A-Za-z0-9,]*)\))?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
STEP0010 EXEC PGM=SORT,PARM='SIZE(MAX),DYNALLOC=(SYSDA,15)',COND=(0,NE)
STEPCTLG EXEC PGM=IEFBR14,COND=(4,LT)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)