package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).+\.[\d]{4}-[\d]{2}\..+`)
var str = `iqn.2019-10.com
eqn.2019-10.com
eqn.209-10.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}