re = /.+\.[\d]{4}-[\d]{2}\..+/m
str = 'iqn.2019-10.com
eqn.2019-10.com
eqn.209-10.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end