// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m).+\.[\d]{4}-[\d]{2}\..+").unwrap();
let string = "iqn.2019-10.com
eqn.2019-10.com
eqn.209-10.com";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}