$re = '/.+\.[\d]{4}-[\d]{2}\..+/m';
$str = 'iqn.2019-10.com
eqn.2019-10.com
eqn.209-10.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);