using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?:You're assigned to kill|You have received a new Slayer assignment from .*:) (.*?)(?: in the Wilderness)?(?:; only | \()(\d*)(?: more to go\.|\))$";
string input = @"You're assigned to kill Dust Devils; only 123 more to go.
You're assigned to kill Suqahs in the Wilderness; only 211 more to go.
You have received a new Slayer assignment from breaklulz: Dust Devils (377)";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}