import re
regex = re.compile(r"^(?:You're assigned to kill|You have received a new Slayer assignment from .*:) (.*?)(?: in the Wilderness)?(?:; only | \()(\d*)(?: more to go\.|\))$", flags=re.MULTILINE)
test_str = ("You're assigned to kill Dust Devils; only 123 more to go.\n"
"You're assigned to kill Suqahs in the Wilderness; only 211 more to go.\n"
"You have received a new Slayer assignment from breaklulz: Dust Devils (377)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")