$re = '/^(?:You\'re assigned to kill|You have received a new Slayer assignment from .*:) (.*?)(?: in the Wilderness)?(?:; only | \()(\d*)(?: more to go\.|\))$/m';
$str = 'You\'re assigned to kill Dust Devils; only 123 more to go.
You\'re assigned to kill Suqahs in the Wilderness; only 211 more to go.
You have received a new Slayer assignment from breaklulz: Dust Devils (377)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);