use strict;
my $str = 'You\'re assigned to kill Dust Devils; only 123 more to go.
You\'re assigned to kill Suqahs in the Wilderness; only 211 more to go.
You have received a new Slayer assignment from breaklulz: Dust Devils (377)';
my $regex = qr/^(?:You're assigned to kill|You have received a new Slayer assignment from .*:) (.*?)(?: in the Wilderness)?(?:; only | \()(\d*)(?: more to go\.|\))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}