import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(((http:\\/\\/)|(https:\\/\\/)){1}(www\\.){0,1}[a-z0-9]+[\\.]{1}[a-z]+[\\/#=a-z0-9\\?\\.\\+\\&\\%\\_\\-]+)";
final String string = "http://php.net/manual/es/refs.basic.text.php";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}