const regex = /(((http:\/\/)|(https:\/\/)){1}(www\.){0,1}[a-z0-9]+[\.]{1}[a-z]+[\/#=a-z0-9\?\.\+\&\%\_\-]+)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(((http:\\\/\\\/)|(https:\\\/\\\/)){1}(www\\.){0,1}[a-z0-9]+[\\.]{1}[a-z]+[\\\/#=a-z0-9\\?\\.\\+\\&\\%\\_\\-]+)', 'i')
const str = `http://php.net/manual/es/refs.basic.text.php`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}