$re = '/(((http:\/\/)|(https:\/\/)){1}(www\.){0,1}[a-z0-9]+[\.]{1}[a-z]+[\/#=a-z0-9\?\.\+\&\%\_\-]+)/i';
$str = 'http://php.net/manual/es/refs.basic.text.php';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);