import re
regex = re.compile(r"(((http:\/\/)|(https:\/\/)){1}(www\.){0,1}[a-z0-9]+[\.]{1}[a-z]+[\/#=a-z0-9\?\.\+\&\%\_\-]+)", flags=re.IGNORECASE)
test_str = "http://php.net/manual/es/refs.basic.text.php"
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")