using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\-?[0-9]+\.??[0-9]*?(?=\.?0*$)";
string input = @"00.00
00.010
0.
11.010
11
123.123
-239.010";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}