import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\-?[0-9]+\\.??[0-9]*?(?=\\.?0*$)";
final String string = "00.00\n"
+ "00.010\n"
+ "0.\n"
+ "11.010\n"
+ "11\n"
+ "123.123\n"
+ "-239.010";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}