$re = '/^\-?[0-9]+\.??[0-9]*?(?=\.?0*$)/m';
$str = '00.00
00.010
0.
11.010
11
123.123
-239.010';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);