re = /^\-?[0-9]+\.??[0-9]*?(?=\.?0*$)/m
str = '00.00
00.010
0.
11.010
11
123.123
-239.010'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end