#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(nintendo|pc|playstation|xbox)[\/]((type\:(article|opinion|reivew|media))[\/](sort\:(date-desc|date-asc|views-desc|views-asc|comments-desc|comments-asc)))"
Local $sString = "xbox/type:article/sort:date-desc" & @CRLF & _
"nintendo/type:media/sort:comments-asc" & @CRLF & _
"pc/sort:views-desc" & @CRLF & _
"playstation/type:opinion/" & @CRLF & _
"playstation/sort:views-asc" & @CRLF & _
"xbox/sort:views-asc/type:article" & @CRLF & _
"playstation/type:media/sort:views-asc" & @CRLF & _
"xbox" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")