$re = '/(nintendo|pc|playstation|xbox)[\/]((type\:(article|opinion|reivew|media))[\/](sort\:(date-desc|date-asc|views-desc|views-asc|comments-desc|comments-asc)))/';
$str = 'xbox/type:article/sort:date-desc
nintendo/type:media/sort:comments-asc
pc/sort:views-desc
playstation/type:opinion/
playstation/sort:views-asc
xbox/sort:views-asc/type:article
playstation/type:media/sort:views-asc
xbox
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);