import re
regex = re.compile(r"(nintendo|pc|playstation|xbox)[\/]((type\:(article|opinion|reivew|media))[\/](sort\:(date-desc|date-asc|views-desc|views-asc|comments-desc|comments-asc)))")
test_str = ("xbox/type:article/sort:date-desc\n"
"nintendo/type:media/sort:comments-asc\n"
"pc/sort:views-desc\n"
"playstation/type:opinion/\n"
"playstation/sort:views-asc\n"
"xbox/sort:views-asc/type:article\n"
"playstation/type:media/sort:views-asc\n"
"xbox\n\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")