import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(nintendo|pc|playstation|xbox)[\\/]((type\\:(article|opinion|reivew|media))[\\/](sort\\:(date-desc|date-asc|views-desc|views-asc|comments-desc|comments-asc)))";
final String string = "xbox/type:article/sort:date-desc\n"
+ "nintendo/type:media/sort:comments-asc\n"
+ "pc/sort:views-desc\n"
+ "playstation/type:opinion/\n"
+ "playstation/sort:views-asc\n"
+ "xbox/sort:views-asc/type:article\n"
+ "playstation/type:media/sort:views-asc\n"
+ "xbox\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}