package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(on-demand\/[a-z0-9\-]+)
`)
var str = `http://video.google.co.uk:80/on-demand/bananas/chantilly`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}