$re = '/(on-demand\/[a-z0-9\-]+)
/';
$str = 'http://video.google.co.uk:80/on-demand/bananas/chantilly';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);