const regex = /(on-demand\/[a-z0-9\-]+)
/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(on-demand\\\/[a-z0-9\\-]+)
', '')
const str = `http://video.google.co.uk:80/on-demand/bananas/chantilly`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}