# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\+[^@]*//;t' <<< "tester+1m2kasdasdm3@gmail.com"