$re = '/\+[^@]*/';
$str = 'tester+1m2kasdasdm3@gmail.com';
$subst = "";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;