import re
regex = re.compile(r"\+[^@]*")
test_str = "tester+1m2kasdasdm3@gmail.com"
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)