#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "\+[^@]*"
Local $sString = "tester+1m2kasdasdm3@gmail.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)