#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=\()[^()]{1,10}(?=\))"
Local $sString = "(some text) some other text -> some text" & @CRLF & _
"(some) some other text -> some" & @CRLF & _
"(12345) some other text -> 12345" & @CRLF & _
"(TooLongStri) -> nothing matched because 11 characters"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")