use strict;
my $str = '(some text) some other text -> some text
(some) some other text -> some
(12345) some other text -> 12345
(TooLongStri) -> nothing matched because 11 characters';
my $regex = qr/(?<=\()[^()]{1,10}(?=\))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}