import Foundation
let pattern = #"(?<=\()[^()]{1,10}(?=\))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
(some text) some other text -> some text
(some) some other text -> some
(12345) some other text -> 12345
(TooLongStri) -> nothing matched because 11 characters
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)