import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{4}(-\\d{2}){2}([^|]+\\|){3})([\\s\\S]*?)\\n*(?=^\\d{4}.*?(?:[^|\\n]+\\|){3}|\\z)";
final String string = "2015-03-03 19:30:47.2725|INFO|MyApp|This is a single line log message.\n\n"
+ "2015-03-03 19:31:29.1209|INFO|MyApp|This log message has multiple\n"
+ "lines with\n"
+ "2015-03-03\n"
+ "a date in it.\n\n"
+ "2015-03-03 19:32:50.1106|INFO|MyApp|This log message has\n"
+ "multiple lines\n"
+ "but just text only.\n\n"
+ "2015-03-03 19:33:20.2683|ERROR|MyApp|This log message has multiple lines but\n"
+ "also some confusing text like\n"
+ "2015-03-03 19:33:20.2683|ERROR| which should\n"
+ "still be a valid log message.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}