const regex = /(^\d{4}(-\d{2}){2}([^|]+\|){3})([\s\S]*?)\n*(?=^\d{4}.*?(?:[^|\n]+\|){3}|\z)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\d{4}(-\\d{2}){2}([^|]+\\|){3})([\\s\\S]*?)\\n*(?=^\\d{4}.*?(?:[^|\\n]+\\|){3}|\\z)', 'gm')
const str = `2015-03-03 19:30:47.2725|INFO|MyApp|This is a single line log message.
2015-03-03 19:31:29.1209|INFO|MyApp|This log message has multiple
lines with
2015-03-03
a date in it.
2015-03-03 19:32:50.1106|INFO|MyApp|This log message has
multiple lines
but just text only.
2015-03-03 19:33:20.2683|ERROR|MyApp|This log message has multiple lines but
also some confusing text like
2015-03-03 19:33:20.2683|ERROR| which should
still be a valid log message.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}